Forum

Welcome, Guest
Username: Password: Remember me
Valuable feedback is priceless. Plus, you can get some extra Render Points :)

TOPIC: Animation render fail - objects missing/blurred

Animation render fail - objects missing/blurred 2 years 11 months ago #949


  • Posts:11 Thank you received: 4
  • BlooFuut's Avatar
  • BlooFuut
  • New RayPumper
  • OFFLINE
  • Karma: 2
Had high hopes RayPump would work for me. Local and RayPump test renders of some of my animation frames was fine. A long low-res local Cycles render showed no problems. So I submitted part of my animation to RayPump and found a couple big problems.
1. Many still objects in most of my frames are blurred as if in motion. Some frames are fine, but most are blurred and unusable.
2. Several frames objects are missing completely
3. One set of frames rendered 10x longer than the other 50 sets thus costing more.

OS: Windows 7
Blender: 2.73 RayPump v1170
•Intel i5 CPU 2.67 GHz RAM 6GB 64bit
blendfile 649 MB
This file uses solid object physics of boxes falling. The boxes have bows that are simulated with the cloth simulator. All is baked and render is submitted with motion blur.

Image showing blurred object (everything behind word 'Presence' is not moving) BAD
0387.png


Image of next frame showing still objects NOT blurred (GOOD).
0388.png


Image showing objects visible (GOOD)
0138.png


Image showing objects missing (BAD)
0139.png


Image capture of RayPump job showing 10x GPU usage on one set of three frames
RayPump.jpg


Your help and consideration for my problem is greatly appreciated.

Thanks,
Scott
The administrator has disabled public write access.

Animation render fail - objects missing/blurred 2 years 11 months ago #951


  • Posts:397 Thank you received: 69
  • blending software ideas
  • melon's Avatar
  • melon
  • PumpOperator
  • OFFLINE
  • Karma: 33
That's interesting. Anyone experiences something similar?

I would love to make some test to find out what causes problems - could you provide some simplified test scene, that shows the issue?
Also - if you want - please calculate how much Render Points were lost for buggy frames - I'll refund that costs.
The administrator has disabled public write access.

Animation render fail - objects missing/blurred 2 years 11 months ago #953


  • Posts:11 Thank you received: 4
  • BlooFuut's Avatar
  • BlooFuut
  • New RayPumper
  • OFFLINE
  • Karma: 2
Thanks melon,

Attached is a small render from my machine of how part of the animation should look.

File Attachment:

File Name: sample0001-0104.avi
File Size: 2,356 KB


Here is a blender file from the beginning of this project that has only two boxes with bows falling.

Since I can't use the output for my animation (98%) of the frames are unusable, all of the RenderPoints were wasted. I'll reply later with the amount when I can look that up.

Thanks again,
Scott
Attachments:
The administrator has disabled public write access.

Animation render fail - objects missing/blurred 2 years 11 months ago #954


  • Posts:11 Thank you received: 4
  • BlooFuut's Avatar
  • BlooFuut
  • New RayPumper
  • OFFLINE
  • Karma: 2
So the total render points used for the animation job was 1,673. Hopefully I can try this again using a credit, but I'll wait to hear if you have any suggestions or solutions.

Thanks again,
Scott
The administrator has disabled public write access.

Animation render fail - objects missing/blurred 2 years 11 months ago #955


  • Posts:397 Thank you received: 69
  • blending software ideas
  • melon's Avatar
  • melon
  • PumpOperator
  • OFFLINE
  • Karma: 33
Thank you for all the sample files and information.

I'll refund the 1673 Render Points now, but playing with files will take some time - especially now, since I'm working on something different during the week :(
But! - If you find any clues how to avoid / fix / cheat / work around / suggestion to RayPump handling / ... - please let me know - I'll be happy to make fixes or updates to tutorials.
The administrator has disabled public write access.

Animation render fail - objects missing/blurred 2 years 11 months ago #971


  • Posts:11 Thank you received: 4
  • BlooFuut's Avatar
  • BlooFuut
  • New RayPumper
  • OFFLINE
  • Karma: 2
I think I figured it out. In the Performance section of Render settings I had tried to optimize my renders but I guess RayPump didn't like the settings. So I unchecked:
Cache BVH
Persistent Images
Use Spatial Splits
Save Buffers

These seemed to solve the problem of blurred images or missing objects.

But there is still the other issue: In a RayPump animation render sometimes one set of frames will take 5X as much renderpoints for no apparent reason.

5XRenderPoints.jpg


Thanks again,
Scott
Last Edit: 2 years 11 months ago by BlooFuut.
The administrator has disabled public write access.
The following user(s) said Thank You: melon

Animation render fail - objects missing/blurred 2 years 11 months ago #972


  • Posts:397 Thank you received: 69
  • blending software ideas
  • melon's Avatar
  • melon
  • PumpOperator
  • OFFLINE
  • Karma: 33
Fantastic feedback, Scott!

I've already tweaked the scripts to automatically set the Performance check as you've shown.
Can you test again some "old settings" sample, to verify if my tweaks work?

EDIT: of course, the issue with overpricing some jobs - I'll look into that ASAP.
Last Edit: 2 years 11 months ago by melon.
The administrator has disabled public write access.

Animation render fail - objects missing/blurred 2 years 11 months ago #977


  • Posts:11 Thank you received: 4
  • BlooFuut's Avatar
  • BlooFuut
  • New RayPumper
  • OFFLINE
  • Karma: 2
I'll try as soon as the connection to RayPump comes back online. In the meanwhile, you can see my finished animation project here:



Thanks to RayPump I was able to finish this faster than I would ever on my home system. My family who also has to use this computer thanks you as well. :)
The administrator has disabled public write access.

Animation render fail - objects missing/blurred 2 years 11 months ago #986


  • Posts:11 Thank you received: 4
  • BlooFuut's Avatar
  • BlooFuut
  • New RayPumper
  • OFFLINE
  • Karma: 2
With RayPump back online I tried a portion of my animation with selections for
Cache BVH
Persistent Images
Use Spatial Splits
Save Buffers

This time the renders worked fine, no glitches.and no jobs overpriced!
Thanks,
Scott
The administrator has disabled public write access.
The following user(s) said Thank You: melon

Service maintenance

SERVICE IS OFFLINE

 

Forum actions

Users online

We have 161 guests and no members online