Help

New here? Make sure you read this!

Inside:

  • installation;
  • first run,
  • tips & tricks;
  • user interface - piece by piece;

 

Register

You will need registered username and password. It will be used later, to connect Render Farm and exchange all the data.

User account should be activated after registration. Activation link will be send automatically after registration. Please make sure to check your e-mail, including the spam folder.

Download

You have to be registered user to get access to download links. Then download the Release Pack for you operating system. It is simply archive file that contains all you'll need: RayPump Client and RayPump add-on.

File should be unpacked - as result you'll have the RayPump Release Pack folder on your hard disk. 

Launch Client

TIP: to make things brief at the start, please close any other applications that heavily use your network (e.g. torrent clients, cloud storage)

 

From the Release Pack folder, launch the RayPump client (raypump.exe under Windows, raypump32/raypump64 binary under Linux, RayPump icon under Mac OS).

Log in using same username and password that you used during website registration. Check the remember me option if you want RayPump to log in automatically in future.

 

 

Click Connect button. RayPump Client content will change, showing something like that:

Keep the client software running in the background - its window can be closed, but make sure you have RayPump's tray icon visible.

Install Blender add-on

In Blender, open User Preferences from File menu, and choose Addons section. Click 'Install from File...' button and navigate to RayPump directory. Select raypump_ui_panel.py file from there.

Select the check-box to enable RayPump add-on. Once it is installed, you might want to click 'Save User Settings' to keep those settings permanent.

From now on, RayPump plug-in will be located in Render Category.

 

Alternatively, you can copy raypump_ui_panel.py file to <Blender>/<version>/scripts/addons directory

 

Work as usual

Select Cycles, as render engine for your project and prepare the scene, just as usual. No extra settings needed.

Launch RayPump job

Once you've decide to launch the render on the RayPump service, go to the Render tab in Properties panel. There's a new section: RayPump II Online Cycles Accelerator. By default it is located at the bottom of the stack, so scroll down.

Leave the default settings for know - Free jobs accelerated with GPU, no tiles used. This is the best option to start with.

Almost done. Now, all you have to do is: 

1. Select job type

RayPump service renders jobs in two different modes: Free and Pro. Similarly, your account has two sets of Render Points: Free and Pro (both shown in RayPump Client window). 

 

Free Render Points Pro Render Points

Automatically assigned to your account, every day.


Free Render Points are used to cover cost for Free type of jobs.

Free Render Points restart at midnight (UTC+1): old points expire, fresh full pack is assigned for next 24 hours.

Can be purchased via PayPal. You'll also get some Pro Render Points after registration and in exchange for valuable feedback.

Pro Render Points are used to cover cost for Pro jobs: Static and Animation.

Pro Render Points do not expire.

 

So, it all comes down to selecting proper job type in Blender (RayPump's panel):

  • Free - uses Free Render Points: 001 PNG frame only , limited resolution and sample count, only GPU acceleration mode;
  • Static - uses Pro Render Points: single frame, selected in Blender, sample count, resolution and format as selected in Blender (with some limitations), possible CPU acceleration;
  • Animation - uses Pro Render Points: whole sequence (range set in Blender) is scheduled as group of Static jobs;

Free job type is default for every new scene in Blender. Also should should always use GPU acceleration, as long as your scene is GPU compatible.

CPU acceleration is available only for Pro jobs - and should be considered as "last chance" option - only for scenes incompatible with GPU.

For more detailed description about Free/Pro differences, check the this page.

2. Click Render Online button

Current scene is been transferred to the Render Farm. Basically you don't have to worry about transfer  and progress - you'll get the status messages (upload done, rendering started, download finished, etc) in your tray icon. Of course, you can always switch to RayPump Client to see current progress and manage jobs.

 

3. Done

Once all the images are ready and downloaded, expand your done job and double-click result folder:

Brief description of Jobs Tree

RayPump II displays all your jobs in organized, expandable tree structure. It is capable of displaying thousands of entries, yet keeping things simple and easy to manage.

Imagine rendering long animation in 4K resolution. Such 'monster-job' will contain sub-jobs for every frame.  Every frame can be again divided to tiles as separate sub-jobs. It happens automatically, giving out pretty long job queue. Even so it can be displayed as single entry, with overall progress, cost and time. And in case you need more details, just expand the tree items, as deep as you need, down to a single tile-job:

For every scene transferred from Blender, RayPump creates root item (named as you scene) in the Jobs Tree. Every root item contains one or more day-items, which can contain one or more hour-items. This way, different version of your project can be easily managed and reviewed. 

Hour-items have little folder icon in Results folder column - double-clicking on it opens folder for that particular shot. Folder contains single image or sequence of images, depending of the job type (free, static or animation). 

Hour-items also have sub-items: frame-range-items, which contain tile-items. Tile-item is the bottom one, meaning it is a single job running on the farm (usually as part of bigger group).

 


 

Any tips for new users?

Find out what's new gradually. This way you'll always know what's going on.

Use Free Render Points

Despite you might have some Pro Render Points assigned to new account - don't use them yet. Play with Free jobs first. Running heavy Pro job having only few Pro Render Points will most probably cause an overdraft (negative Render Points). This is something you want to avoid, because:

Getting negative Render Points will effectively lock the downloads

First - test your new work-flow

Word of advice: don't start with your biggest, heaviest project yet. It is much wiser to start with basic, test scenes. Even a simple cube scene for the starters is OK.

Then run every day jobs

Once you'll make sure that there are no connection (firewall/proxy) issues, it is time to start working with bigger files. Remember: the first upload of the scene will take much longer - whole file has to be transferred. But once you got that scene online, the real workflow acceleration begins. 

Finally - run the heavy jobs

After a while, you'll get used to new workflow with Blender/RayPump combo. You'll be surprised, how fast it can be for every day jobs! And once you're happy with that, you can try something heavy, like animation or big-res image. 


 

Uploads made smart

Only the first time uploading the scene, the whole data has to be transferred. Following uploads - even for pretty big scenes - will take much less, usually few seconds for typical scene changes.

This hopefully should speed-up your workflow greatly, reducing one of major flaws of classic render farms.

 

Important note: smart upload works on file names. If you rename the scene's file (using Save As), it will be treated as completely new job, causing the upload start from scratch.


 

RayPump service consist of three parts:

  • RayPump Add-on -  additional Blender's panel in Properties->Render section;
  • RayPump Client -  separate program that usually runs in background and takes care of data preparation and transfer;
  • RayPump Farm - something you want to have access to :)

RayPump Panel

Panel functionality is pretty simple:

Job Type

Select Free to use Free Render Points, Static or Animation to use Pro Render Points.

Default value: Free

Use tiles

Speeds up big resolution static renders. Image is split to tiles and send to many servers. Number of tiles is adjusted automatically,  depending of resolution and sample count.

Use tiles is experimental feature, in some cases using tiles can be bit more expensive or job might fail to complete.

Default value: off

Not accessible with Free job type;

Acceleration

Select online devices to be used for rendering. GPU is highly recommended, as it is much faster (equals: cheaper). CPU is experimental feature, slow and expensive - intended only for scenes incompatible with GPU.

Default value: GPU

CPU not accessible with Free job type;

Render Online

Schedules the jobs (meaning: automatic preparation, upload, rendering and download).

Help

Open link to this manual in your web browser.

RayPump Client

RayPump Client interface is fairly simple. It is single window with almost all functionality visible at once:

 

Tooltips

Most of the user interface elements display short description after you hover them with the mouse cursor. For example, price conversion from Render Points to Euro can be found in Job Tree, after hovering RP cost:

 Render Points bar

Displays Render Points assigned to your account. 

Pro Render Points

Used with Static and Animation jobs. Can be purchased via PayPal, but also assigned by service operator in exchange for your help, feedback, bug-reporting etc.There are also promotions and projects that might include Render Points.

Free Render Points

Free Render Points are assigned to your account for each day. To use those points, you should select 'Free' type of job in Blender's panel. Once you reach the daily limit, no more Free jobs can be scheduled that day. 

There's no limit in job count - for example, if limit is 80 Render Points daily, then you can make 80 jobs for 1 RP each, or two jobs for 40 RP each. You can even exceed the limit with heavier jobs. If that happens The "overdraft" will be taken from next day's Free Render Points.

Counter restarts everyday, at midnight (time-zone: UTC+1).

Upload speed 

Limits the speed of data transfer to and from Render Farm. Can be useful to make your connection more responsive with other programs. It is also helpful under Windows to prevent some errors with full-speed transfers.

Animated logo

Not only fancy gadget, but the tool :) Spinning logo indicates that Farm is working on your job(s). Once it stops, it usually means that results are ready and downloaded.

Button bar

Contain job management buttons:

  • Cleanup - removes all done jobs from the tree, also refreshes the Render Points bar;
  • Cancel upload - aborts current transfer;
  • Cancel all - removes all your jobs on the Farm - in case of very long queues some jobs might not be seen in Jobs Tree, but those will be also canceled;
  • Remove selected - all jobs selected in Job Tree will be canceled. If selected items contain children, those will be also canceled;

Job Tree

Described briefly in first part of the tutorial.

Destination bar

Shows the path on your local disk, where all the result images will be downloaded to. You can change that path clicking it, or open the folder with Open button. 

All the results will be saved in sub-folders, like this:

As you see, folder names are self-sorted, much like Jobs Tree - showing you the scene name and date/time of its creation. Static and Free job folders will contain single image, while Animation will contain the while rendered sequence, ready to post-processing.

 Status bar

Status bar shows what is the last or current operation performed by service (program or Render Farm). It usually works in conjunction with tray messages, giving better feedback of what's going on.

Extras menu

Top bar is more than fancy decoration - it has "hidden" advanced options you can access with mouse right click:

From version 1.16 you can also click Extras to open the same menu:

Additional menu opens and it contains:

  • Add Render Points - opens your web browser for purchasing Pro Render Points;
  • Activity log - opens web browser to check/download render activity (Pro jobs only);
  • Help - opens web browser on Help page;
  • About - copyright, version, user information;
  • Clear remote buffer - in case of upload issues, user can wipe out online content. Use with care.
  • Force download - force the service to download ready files, even if some jobs are not finished. Use with care.
  • Disconnect
  • Quit

 

Need more?

There's a more detailed information about usage, costs and known issues in this Ask section. And if you'd need even more - check out the Talk section. There's already plenty of answers and new questions will always be answered.

 

Login Form

Service maintenance

SERVICE IS OFFLINE

 

Feedback Box

Questions?

The best place to find help is Help and Forum sections.

Alternatively, contact by e-mail. I'll be happy to answer.

Blender version used by RayPump

Blender (stable): 2.75a
RayPump Server: 1.170